OBIEE11g: Error:[nQSError: 43126] Authentication failed: invalid user/password. error when Logging into Answers/analytics

After restarting all services (Admin server, Node manager, Managed server and OPMN), users were not bale to login to Presentation Services (commonly known as answers/analysis). It was showing invalid user/password error.

Log file:  /u01/APP/OBIEE/instances/instance1/diagnostics/logs/OracleBIServerComponent/coreapplication_obis1/nqserver.log

error: [2017-08-02T21:53:52.000+05:30] [OracleBIServerComponent] [ERROR:]1] [] [] [ecid: 0000LqZjaJG4qmmpsoL6iX1PWVhs000002,0:26:1:6] [tid: eaed6700] oracle.webservices.provider.ProviderException: java.lang.RuntimeException: oracle.bi.security.service.SecurityServiceException: SecurityService::authenticateAccess is denied for the specified credentials/identity.
[2017-08-02T21:53:52.000+05:30] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: 0000LqZjaJG4qmmpsoL6iX1PWVhs000002,0:26:1:6] [tid: eaed6700] [nQSError: 43126] Authentication failed: invalid user/password.

Root Cause: The BISystemUser account has become locked.

Solution:

  1. Log in to the WebLogic Server Administration Console.
  2. Navigate to Security Realms > myrealm > Users and Groups > Users > BISystemUser > Password
  3. Reset the password to same as of old password (i.e. you just need to reset to same password) and save.
  4. Login to Enterprise Manager.
  5. Navigate to WebLogic Domain  and right click on bifoundation_domain.
  6. Click on Security > Credentials
  7. click on oracle.bi.system and then system.user
  8. Then click on edit on top of this table and reset the password same as you set for BISystemUser in WebLogic Server Administration Console.
  9. Restart OPMN services and wait (i did so) for 10 minutes before login into Answers.
  10. It should work.

 

Thank You

Akash (@akashdgarg).